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1 1  Introduction Introduction

EnterpriseSheet provides code level integration to build your business spreadsheet inside your 

existing application. It is an online spreadsheet application running on your server and you 

control the whole security levels of your data.

With Enterprise Spreadsheets, you can easily create, share, and edit spreadsheets online. Here are 

a few specific things you can do:

● Import file with .xlsx, .csv. format and export as .xlsx type.

● Format your cells and edit formulas so you can calculate results and make your data look 

the way you want it.

● Supports different kinds of formulas with name manager.

● Cross sheet reference

● Add condition

● Add validation

● Group, split, auto-fill and filter

● Create pie, bar, column charts from the selected data range

● Multiple worksheet support

To see the application, please visit: https  ://  www  .  enterpriseSheet  .  com

http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/
http://www.enterprisesheet.com/enterpriseSheetFormulas.jsp
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2 2  Create and save a Spreadsheet Create and save a Spreadsheet

There are different ways of getting started using EnterpriseSheet, you can create a new 
spreadsheet or upload a Microsoft Excel file or CSV file from your computer.

2.1  Create Spreadsheet

To create a new spreadsheet, you click the menu File → New  → Sheet  button and start entering 
information.  EnterpriseSheet will automatically save your work every few seconds. At the top 
and right of the spreadsheet, you will see text that indicates when your spreadsheet was last 
saved. You can access your spreadsheet at any time by clicking the Open button to open your 
Documents List.

2.2  Create Template Spreadsheet 

To create a new template spreadsheet, you click the menu File → New  → Template Sheet and 
start entering information.  This file will be saved as a template.

2.3  Create Sheet from Template

To create a new spreadsheet from existing template, you click the menu File → New  → Sheet 
from Template button. A popup window with existing template files will appear and you can 
select one of template to create a new sheet. System will copy existing template information into 
your new sheet file.

2.4  Open sheet

To open an existing spreadsheet, you click the menu File → Open  button. A popup window with
existing files will appear and you can select one of spreadsheets to open. Double click the sheet to
open the file.
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2.5  Upload a file

To upload a file, go to the File menu and click the Import button, you will be able to upload the 
those types of files (.XLSX and .CSV) and convert them into EnterpriseSheet file format.

If file is succeed uploaded without error, spreadsheet file will be opened automatically. 

Otherwise, an error message appears which allow your open and view the detail failed cell 

information.

For performance consideration, we recommend setting the size to less than 2048K.

2.6  Save sheet as

To save an existing file as a new file, you can click the menu File → Save as  button. A popup 
window with existing files appear and you can enter new file name to process. Click Save button 
to finish your process.
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3 3  Edit and format the spreadsheet Edit and format the spreadsheet

3.1  Edit content in a cell

To enter content in an empty cell, click the cell and add your content. To edit a cell that already 

has content, double-click the cell and edit the content. You can also click the "F2" key to start 

editing in the selected cell.

3.2  Format data in the cells

You can format data in your spreadsheets in a variety of ways using the options in the spreadsheet
toolbar. You can hover over an icon on the toolbar to see a message describing what that option 
can do. You can also use menu button to process data format.

Here are the main formatting options:

• Undo or redo last operation

• Change the number, date or currency format

• Add number custom

• Format cell contents

• Change font size

• Add bold or strike through

• Change color of the text or a background color

• Add different type of borders

• Align text

• Merge cells

• Wrap text

• Format brush

• Add formulas

• Disable/enable cell



FeyaSoft Inc EnterpriseSheet Functions Page 8 of 40

3.3  Cut, copy and paste

EnterpriseSheet allows your to copy and paste text and images between your cells or tabs. You 

can either use keyboard shortcuts (Ctrl+C and Ctrl+V), the options under the Edit menu, or the 

icons in the toolbar to copy and paste. 

Here are some examples of things you can do:

• Copy a set of cells in a spreadsheet, and paste it into another place in the spreadsheet as a 

properly formatted table

• Copy something in your work computer and paste it into your spreadsheet cell

When you copy data, the border of the cell or range of cells will turn solid to help you remember 

where you copied the data from. When you cut data from a cell or a range of cells, you'll see a 

dotted line around the cell(s).

Copying and pasting in EnterpriseSheet copies all properties of a cell into the cell you're pasting 
into, including text, formatting, and data validation. The paste special option gives you more 
control about what properties you're copying and pasting into a range of cells. An icon is popup 
during paste the cell information, in the drop-down list of this icon, you can select different paste 
options.

• Paste
• Paste only with data and calculate
• Paste only with calculate and format
• Only paste with style
• Reverse paste

3.4  Insert an image into a spreadsheet or cell

By selecting Insert from the toolbar and selecting the Image menu, you can select an image from
the system and insert it, or you can insert the URL of the image.
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By selecting Insert from the toolbar and selecting the In-cell menu,, you can select an image 
from the system and insert into the cell, or you can insert the URL of the image to the selected 
cell. 

Before you select an image to insert into the spreadsheet, you might need to upload an image to 
the system first. After that, this image can be inserted into different spreadsheet as your like.

3.5  Add, edit or delete comment

To add a comment to your spreadsheet, follow these steps:

• Click the cell you want to insert a comment
• Right-click the cell and select Insert Comment
• A popup window will appear
• Enter the text of your comment
• An orange mark will show in the top left corner of the cell where you inserted the 

comment

To view a comment after it has been inserted hover the mouse over the orange comment 
indicator. Then, right-click the cell and select one of the menu options to edit or delete the 
comment.

You can also insert comments from Insert menu and click Insert comment button.

3.6  Merge Cells

To merge cells horizontally or vertically in a spreadsheet, select the cells you wants to merge and 
select Merge icon in the toolbar and click Combine cells to process. There are 3 options allow 
your to process merge:

• Merge cells
• Merge cells in column
• Merge cells in row

If you want to unmerge a selected range of cells, select the merged cell(s) and select Merge icon 
in the toolbar and click Cancel merged cell button to process. 
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3.7  Format data, numbers

You can format numbers in the sheet in a variety of ways, including decimal, percent, fraction 
and scientific. You can even build your custom number. 

To format or change the format of numbers in a sheet, follow these steps:

• Select the range of cells you want to format or update

• Click Format menu and you can select 
1.     Number format
2.     Number custom
3.     Number special

• Select the format your want to apply to those cells.

3.7.1  Number Custom

You can apply number custom format to the selected cells. 

Select the cells you want to format
Click Format menu and hover over Number custom
Select one of the format to apply for your data.
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You can also create a new custom format. Click Add custom number format button to add new 
format.

Here lists some common syntax characters that you can use to create a custom number format.

0 A digit in the number. A 0 will appear in the results.

# A digit in the number. A 0 will not appear in the results.

$ Format number as a dollar value

. Format numbers with a decimal point.

/ Format number as a fraction

% Format number as a percent

e Format number as an exponent
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You can use colors in the formatting, for example to differentiate between positive and negative 
numbers, by adding a color in brackets (for example, [Blue]) anywhere within the first part of the 
format. The colors that can be used are:

• Black

• White

• Red

• Blue

• Green

• Magenta

• Yellow

• Cyan

A list of example format:

[magenta]RMB¥#,##0.00;[green]-RMB¥#,##0.00;[red]零;@

[Blue]#,##0.00;[Red]-#,##0.00;[yellow]zero;@

$#,##0.00;[Red]-$#,##0.00;[Red]ZERO

#,##0.00;[Red]-#,##0.00

# ??/??

# ??/16
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0.00%

0.0e+00

3.7.2  Number Special

You can apply number special format to the selected cells. Each locale has some special format 
like phone, SIN number etc.

Select Format menu and select Number special. You can apply phone, SIN etc to your cells.

3.8  Format currency

You can format numbers in the sheet in a currency to correctly display the data in your 
spreadsheet. To do this, select the cell you want to format and click Format menu and select 
Currency button. Or you select the currency icon to process.
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From the drop down list, you can select different currency. You can also choose use symbol or 
currency code to process, and select decimal places too. 

For negative numbers, there are 3 pre-defined formats for your to select and apply.

3.9  Format date

You can format numbers in the sheet in a date to correctly display the data in your spreadsheet. 
To do this, select date icon from toolbar to process. 

Click More... button under date icon, you will be able to apply more date format.
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3.10  Edit a link

You can just enter an url to the cell and link will be auto added. When the cell is selected, a pop-
up window appears. You can click Remove to delete the hyperlink. Right click and show 
contextmenu to add hyperlink.

3.11  Add Condition

Use conditional formatting rules to get a visual summary of complex or changing data. You can 
format cells to change the text or background colors if they meet certain conditions, for example 
if the cells contain certain words or number.

Select a range of cells and click Edit in the menu bar and go to Condition management... 
button. Right side bar appears, you can add condition by select different kinds of rules.

3.11.1  Condition for highlighting cell
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Here lists the condition for highlighting cell which can be applied to the range of cells

• Greater than …

• Less than …

• Equal …

• Between …

• Include …

• A Date Occurring …

• Repeat value …

You can apply a range of cells for the different kind of condition as following example.

3.11.2   Calculate for highlighting cell

Here lists the calculate for highlighting cell which can be applied to the range of cells

• Top 10 …

• Top 10% …

• Bottom 10 ….

• Bottom 10% …

• Above average …

• Below average value …
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You can apply a range of cells for the different kind of condition as following example.

3.11.3  Colorful bar

Select a range of cell data and apply colorful bar to the data.

3.11.4  Color gradation

Select a range of cell data and apply color gradation to the data.

3.12  Paint format

You can apply formatting or conditional formatting rules you've used on one set of cells to 
another separate set of cells using the Paint Format tool, where "paint" is used figuratively to 
describe copying the formatting rules. The types of formats that you can paint are style, fonts, 
number formats and conditional formatting.
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If the range of cells you're painting the formatting across is larger than the source area, the 
formatting will tile across the target area.If the range of cells you're painting the formatting across
is larger than the source area, the formatting will tile across the target area.

To paint formatting from one area across another area, follow these steps:

• Select the range of cells that contain the formatting and/or conditional formatting rules 
you'd like to paint across another range of cells.

• Click the Paintbrush toolbar icon.

• Select the range of cells you'd like the formatting to be copied across. The cell formatting
will then be applied to the range of cells you've selected.
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4 4   Spreadsheet sheets, rows and columns  Spreadsheet sheets, rows and columns

4.1  Copy, paste, rename and delete sheet

You can make a duplicate copy of any sheet in a spreadsheet. That copy can be made within the 
same spreadsheet. To copy a sheet to another spreadsheet:

● At the top or bottom of a spreadsheet, right-click the mouse for the sheet name
● From the menu, click Copy
● enter the new sheet name from the popup window
● Click OK to create this new sheet

To rename a single sheet from a spreadsheet, first go to the sheet you want to remove. Right click
on the sheet tab, and select Rename from the menu. Enter new name for process.

To delete a single sheet from a spreadsheet, go to the sheet you want to remove, right-click on the

Sheet tab, and select Delete from the menu. A warning dialog will appear. If you want to delete 

the sheet, click OK.

You can also add color to the sheet tab by select Color button and apply one of color.

4.2  Add and delete rows and columns

To add a row or column to a spreadsheet, right-click on the gray area containing the column letter
or the row number and select the action you want to complete. For example, to insert a blank 
column to the left of the column you selected, you would select Insert...  from the Insert menu in 
the context menu. To delete a row or column, select Delete  row from the drop-down menu in the 
context menu (right click mouse and context menu will appear.)
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4.3  Change row height and column width

To change the row height and/or column width, place your cursor at the outlying border next to 
either the number or label of the column you want to re-size. Then, drag your cursor with the 
mouse to re-size the row width or column height.

You can also re-size rows or columns using the mouse right-click menu and entering the row 
height or column height in the Context menu.

4.4  Freeze or unfreeze columns and rows

Freezing rows and columns allows you to keep some of your data in the same place as you scroll 
through the rest of your spreadsheet. This is particularly useful if you have headings or labels that
you want to keep in one place as you scroll through a large data set.

You can freeze different rows or columns in any particular sheet. Here's how:

• Select the row or column you want to freeze

• Right-click the mouse and select the Freeze sheet menu

• The column or row will now be frozen

• Click Cancel freeze to unfreeze it.

4.5  Hiding rows or columns

To hide one or more rows, select the rows by clicking the number of rows and right-clicking and 

selecting Hide from the drop-down menu. The row's number will no longer be visible.

To show the hidden rows, select the rows including the hidden rows and right-click and select 

Show from the drop-down menu. The row's number will be visible again.

To hide and show columns process the same action as above.
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4.6  Split sheet

To split the sheet horizontally, hover the mouse into the top/right corner and click and drop. 

There will now be two different windows – each with their own scroll bar.

To split the sheet vertically, hover the mouse into the bottom/right corner and click and drop. 

There will now be two different windows – each with their own scroll bar.

To cancel the split, right-click on the Context menu and then select the "Cancel Split" button..  

4.7  Hide and show grid line

To hide and show the grid line, select the View menu,  and click Hide gridline. The line in the 

sheet will now be hidden. To display the grid line, click Show gridline.

4.8  Group and ungroup the rows or columns

The GROUP and UNGROUP feature provides an easy and transparent way to hide and unhide 

rows and columns.

• Highlight the rows or columns what you want to be grouped.

• Click the mouse right button and open contextmenu, select Add Group icon to group 

them together.

• And the expand button - or + is added on the left part of rows. Click - or + button will 

allow your to show or hide the rows or columns.
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To ungroup rows or columns, 

• Highlight the rows or columns what you want to be ungrouped.

• Click the mouse right button and open contextmenu, select Cancel Group icon to 

ungroup them.
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5 5   Formulas  Formulas

Formulas in the EnterpriseSheet are used to perform calculations. EnterpriseSheet Formulas 

range from basic mathematical operations, such as addition and subtraction, to complex 

engineering and statistical calculations. You can add a formula to any cell in a spreadsheet by 

typing an equal sign (=) followed by the name of the function.

To start the formulas, you can type the cell with = and following name, the existing formulas will 

be popped as following image. You can use your mouse to select cell or cell range. Different 

range can have different color as following example.

5.1  Formulas Types

EnterpriseSheet includes the following types of formulas:

• Numeric / Mathematical Functions

•  Logic Functions

•  Lookup / Reference Functions

•  Statistical Functions

•  String Functions

•  Date Functions

•  Financial Functions

•  Information Functions

• Engineering Functions
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Click this link to see more details about   EnterpriseS  heet formulas.

5.2  Range name manager

You can also define your range name manager by click Insert → Define Named Range in the 

menu bar or right click to open context menu to select it. It can make your formulas much easier 

to understand and maintain. You can define a name for a cell or call range. Once you adopt the 

practice of using names in your workbook, you can easily add, update, and manage these names.

You can also check the site button to get existing name range in the spreadsheet.

http://enterprisesheet.com/enterpriseSheetFormulas.jsp
http://enterprisesheet.com/enterpriseSheetFormulas.jsp
http://enterprisesheet.com/enterpriseSheetFormulas.jsp
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6 6   Work with Data  Work with Data

6.1  Select the data range

You can use mouse to select the range of data in the spreadsheet. You can also use the keyboard 

(Shift + key up/down/left/right) to select the range of data.

6.2  Apply table template
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Table template in the spreadsheet makes it easier for user to decorate the data with different 

colorful view. You can select Edit menu and click Table style... to process. You can also click 

table icon from side bar to implement.

There have 3 types of table color

• light color

• dark color

• deep dark color

Select a range of cells and click one of table template to apply your format. You can also clear it 

by click Clear Table Template button.

6.3   Apply cell style

Cell style in the spreadsheet makes it easier for user to decorate the cell with different colorful 

view. You can select Edit menu and click Cell style... to process. You can also click styl icon 

from side bar to implement.
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Select a range of cells and click one of cell style to apply your format. 

6.4  Validation

Validation feature in the spreadsheet makes it easier for user to validate the range of cell data.

• Select a range of cells

• Click Data menu for Validation... button.

• Enter you validation information, such as: set criteria, cell range, hint text.

• Click SAVE to implement

There have 4 kinds of criteria in the validation

• Number (between, not between, >, >=, <, <=, =, !=)

• Text (Contain, Not contain, Equal, Is valid email, Is valid URL)

• Date (Is valid date, Equal, Before, On or before, After, On or after, Between, Not 

between)

• Item list
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You can choose any of validation rules and apply to the selected range of cells. Click Remove 

validation button to remove it,
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6.5  Create an in-cell dropdown list

You can create dropdown lists in the cell by choose Insert menu → Dropdown list button. A 

popup window appears for your to create and edit dropdown list.

You can also force user only select the value from drop down list. Or you can allow user enter 

data in the cell with dropdown list. After a dropdown list is created, you can apply it to the cells 

to build in-cell dropdown list.

6.6  Create an in-cell Checkbox

Select a range of cells and you can create checkbox in the cell by choose Insert menu → 

Checkbox button. 
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6.7  Create an in-cell Radio button

Select a range of cells and you can create radio button in the selected range of cells by choose 

Insert menu → Radio button. 

6.8  Filter and sort data

Filter feature in the spreadsheet makes it easier for user to analyze and view data by hiding the 

data that you temporarily want to take out of view. When you want all of your data to be visible 

again, all you have to do is clear the filter.

Following the steps to process filter

• Select the range of cells you’d like to apply the filter to.

• Click Filter icon in the toolbar. And a drop-down icon appear in the first selected cell.

• Click this icon to popup a filter window. Enter you criteria to process filter.

• After click OK button, the filtered row will be hidden.
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To clear filter, select the filter drop menu and click Clear filter button. The filter will be removed

from your selected range of cells. Drop-down menus will disappear from the first row of the 

selected range of cells.

You can also sort the data in the select range of cells. However, after your cancel filter, your 

sorted data will not come back.

6.9  Auto fill data

You can use auto fill feature to repeat information or complete a pattern of content in the 

spreadsheet. See the following steps to process:

• Enter your content.

• Highlight the cells. A small black box appears in the lower-right corner.
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• Click the blue black and drag it to select additional cells where you'd like your content to 

repeat.

If Auto-Fill recognizes a pattern in the content of the selected cells, it fills in the remaining items 

to complete the pattern. In the example shown here, it finished the pattern by auto-filling 

Thursday, Friday, Saturday, etc. If Auto-Fill doesn't recognize a pattern, it will just repeat the 

content that was highlighted. 

6.10  Find and replace

In the Edit menu, select Find and Replace... button to let your easy find the information in your 

sheet. You can also replace the content by select replace function.
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6.11  Increase or decrease the decimal places

For numbers that are already entered on a worksheet, you can increase or decrease the number of 

places that are displayed after the decimal point by using the toolbar buttons.

• Select the cell or range of cells that contains the numbers for which you want to change 

the decimal places.

• On the toolbar, click Increase Decimal to display more digits after the decimal point. 

Click Decrease Decimal to display fewer digits after the decimal point.
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7 7   Functions  Functions

7.1  Cross sheet reference

If you want the value from a cell in one sheet to show up in a cell in another sheet, you set up a 

formula to point back to the source data. Let's say you are on Sheet2 and want to get the value 

from Sheet1, cell A19. In a cell on Sheet2 you could manually enter with the formula =Sheet1!

A19.

Please enter the following format if tab name included space: ='Sheet 2'!A1

7.2  Relative And Absolute References

EnterpriseSheet accepts cell references in what are called absolute and relative ranges. Absolute 

ranges have a $ character before the column portion of the reference and/or the row portion of the

reference. Relative ranges do not use the $ character. The $ character indicates to EnterpriseSheet

that it should not increment the column and/or row reference as you fill a range with a formula or 

as you copy a range. 

For example A1 is a relative range, while $A$1 is an absolute range. If you enter =A1 in a cell 

and then fill that cell down a column, the '1' in the reference will increment in each row. Thus, the

formula in row 50 would be =A50. However, if you enter =$A$1 in a cell and fill down, the range

reference will remain $A$1 -- it will not increment as you fill or copy down a column.

Type Description
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$A$1 Both the column and row reference are fixed. Neither will be incremented or 

changed during a copy or fill operation.

$A1 Only the column reference is fixed. It will not change during a fill or copy, but the 

row will change.

A$1 Only the row reference is fixed. It will not change during a fill or copy, but the 

column will change.
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8 8  Add Charts in the spreadsheet Add Charts in the spreadsheet

EnterpriseSheet lets you create charts to visualize a data set. You can find a list of chart types, 

customization options, and information about charts for your selection of data.

8.1  Create Chart

Follow the following steps to create the chart for your selected data.

• Enter the data in the spreadsheet, and select the range of data for process.

• Click Chart button in the Edit menu.

• Chart wizard side bar is displayed for your to set the detail of chart. You can also click 

chart icon from side bar to process.

• Click Insert button to insert chart to the spreadsheet.

The following lists the charts we supported at this moment.

• Column Chart 
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• Area Chart 

• Pie Chart 

• Line Chart 

• Bar Chart

• Scatter Chart

• Radar chart 

• Column mini chart 

• Gain/lose min chart

8.2  Edit chart

Click the chart and select from top right setting icon, you will be able to edit the generated chart.
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To delete chart, click Delete chart button. 
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9 9  Size limit Size limit

For enterprise spreadsheet, Every time a cell is updated, any cell that references it will also be 

recalculated. To improve performance, there are several size limitation for the spreadsheet:

• Number of cells: 250,000 total cells across all sheets

• Number of columns: 256 columns per sheet

• Number of formulas: 20,000 cells containing formulas across all sheets

• Number of tabs: 100 sheets per workbook
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10 10  Keyboard shortcuts Keyboard shortcuts

Keyboard shortcuts let you take a particular action in your spreadsheet by pressing a series of keys on 

your keyboard.  

 Description  Key

 Formulas Keyboard navigation         Enter formulas and use arrow key to select the cell.  Use 

SHIFT + arrow key for multiple cell selections.       

 Find & Replace  Ctrl + F

 Open the file  Ctrl + O

 Bold    Ctrl + B 

 Underline    Ctrl + U

 Italic  Ctrl + I

 Undo  Ctrl + Z

 Redo  Ctrl + Y

 Cut  Ctrl + X

 Copy  Ctrl + C

 Paste  Ctrl + V

 Insert comment  Ctrl + Alt + M

 Insert Link  Ctrl + K

 Align Left  Ctrl + Shift + L

 Align center  Ctrl + Shift + E

 Align Right  Ctrl + Shift + R
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